Unity2019默认只能打包Android 9.0(29)的APK,此时打包其他版本的会有下面的提醒

那么要安卓其他版本的APK,怎么办呢
首先,找到安装Unity3D2019版本的JDK、Android SDK所在目录。

新建文件夹,Copy OpenJDK和 SDK两个文件夹

其次,最先设置
1、JDK环境设置这里就不说了,之前都有。
2、升级Android SDK,打开cmd,进入适才复制文件SDK/tools/bin路径下
3、运行SDKmanager --list可以查看当前Android SDK的内容,需要安装的包也在列表中
4、运行sdkmanager 对应的包,安装,也可sdkmanager -- uniNStall 对应卸载的包名

最后,重新启动Unity3D ,设置jdk和sdk